CVE-2022-34459
High
Description
Dell Command | Update, Dell Update, and Alienware Update versions prior to 4.7 contain a improper verification of cryptographic signature in get applicable driver component. A local malicious user could potentially exploit this vulnerability leading to malicious payload execution.
SeverityHigh
CVSS7.8
Exploit probability—
ProductDell Alienware Update
PublishedFeb 1, 2023
First seenFeb 1, 2023
Weakness typeCWE-347CWE-347
How to fix
Update
- dell alienware_update4.7.1 or later
- dell command_update4.7.1 or later
- dell update4.7.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| dell alienware_update | v < 4.7.1 | 4.7.1 |
| dell command_update | v < 4.7.1 | 4.7.1 |
| dell update | v < 4.7.1 | 4.7.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.