CVE-2022-3474
Medium
Description
A bad credential handling in the remote assets API for Bazel versions prior to 5.3.2 and 4.2.3 sends all user-provided credentials instead of only the required ones for the requests. We recommend upgrading to versions later than or equal to 5.3.2 or 4.2.3.
SeverityMedium
CVSS4.3
Exploit probability—
Product
Google Bazel
PublishedOct 26, 2022
First seenOct 26, 2022
Weakness typeCWE-522CWE-522
How to fix
Update
- google bazel4.2.3, 5.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| google bazel | 3.1.0 ≤ v < 4.2.3, 5.0.0 ≤ v < 5.3.2 | 4.2.3, 5.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.