CVE-2022-35916

Medium

Description

OpenZeppelin Contracts is a library for secure smart contract development. Contracts using the cross chain utilities for Arbitrum L2, `CrossChainEnabledArbitrumL2` or `LibArbitrumL2`, will classify direct interactions of externally owned accounts (EOAs) as cross chain calls, even though they are not started on L1. This issue has been patched in v4.7.2. Users are advised to upgrade. There are no known workarounds for this issue.

SeverityMedium
CVSS5.3
Exploit probability—
ProductOpenzeppelin Contracts
PublishedAug 1, 2022
First seenAug 1, 2022
Weakness typeCWE-669CWE-669

How to fix

Update
  • openzeppelin contracts4.7.2 or later
  • openzeppelin contracts_upgradeable4.7.2 or later
  • @openzeppelin/contracts4.7.2 or later
  • @openzeppelin/contracts-upgradeable4.7.2 or later

Affected products

ProductAffected versionsFixed in
openzeppelin contracts4.6.0 ≤ v < 4.7.24.7.2
openzeppelin contracts_upgradeable4.6.0 ≤ v < 4.7.24.7.2
@openzeppelin/contractsnpm4.6.0 ≤ v < 4.7.24.7.2
@openzeppelin/contracts-upgradeablenpm4.6.0 ≤ v < 4.7.24.7.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.