CVE-2022-35925

Medium

Description

BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually.

SeverityMedium
CVSS5.3
Exploit probability—
ProductBookwyrm
PublishedAug 2, 2022
First seenAug 2, 2022

How to fix

Update
  • joinbookwyrm bookwyrm0.4.5 or later

Affected products

ProductAffected versionsFixed in
joinbookwyrm bookwyrmv < 0.4.50.4.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.