CVE-2022-35946

Medium

Description

GLPI stands for Gestionnaire Libre de Parc Informatique and is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. In affected versions request input is not properly validated in the plugin controller and can be used to access low-level API of Plugin class. An attacker can, for instance, alter database data. Attacker must have "General setup" update rights to be able to perform this attack. Users are advised to upgrade to version 10.0.3. Users unable to upgrade should remove the `front/plugin.form.php` script.

SeverityMedium
CVSS5.5
Exploit probability—
ProductGlpi
PublishedSep 14, 2022
First seenSep 14, 2022
Weakness typeCWE-89SQL injection

How to fix

Update
  • glpi-project glpi10.0.3 or later

Affected products

ProductAffected versionsFixed in
glpi-project glpiv < 10.0.310.0.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.