CVE-2022-36023

High

Description

Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.

SeverityHigh
CVSS7.0
Exploit probability—
ProductHyperledger Fabric
PublishedAug 18, 2022
First seenAug 18, 2022

How to fix

Update
  • hyperledger fabric2.4.6 or later
  • github.com/hyperledger/fabric2.4.6 or later

Affected products

ProductAffected versionsFixed in
hyperledger fabricv < 2.4.62.4.6
github.com/hyperledger/fabricGo2.4.0 ≤ v < 2.4.62.4.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.