CVE-2022-36024

High

Description

py-cord is a an API wrapper for Discord written in Python. Bots creating using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the `application.commands` scope without the `bot` scope. Currently, it appears that all public bots that use slash commands are affected. This issue has been patched in version 2.0.1. There are currently no recommended workarounds - please upgrade to a patched version.

SeverityHigh
CVSS7.5
Exploit probability—
ProductPy-cord
PublishedAug 18, 2022
First seenAug 18, 2022

How to fix

Update
  • py-cord2.0.1 or later

Affected products

ProductAffected versionsFixed in
py-cordPyPI2.0.0 ≤ v < 2.0.12.0.1
pycord_development pycord2.0.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2022-36024 · Py-cord · Dark Radar