CVE-2022-36036
Description
mdx-mermaid provides plug and play access to Mermaid in MDX. There is a potential for an arbitrary javascript injection in versions less than 1.3.0 and 2.0.0-rc1. Modify any mermaid code blocks with arbitrary code and it will execute when the component is loaded by MDXjs. This vulnerability was patched in version(s) 1.3.0 and 2.0.0-rc2. There are currently no known workarounds.
How to fix
- mdx-mermaid_project mdx-mermaid1.3.0 or later
- mdx-mermaid1.3.0, 2.0.0-rc2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| mdx-mermaid_project mdx-mermaid | 0.0.1 ≤ v < 1.3.0, 2.0.0 | 1.3.0 |
| mdx-mermaidnpm | v < 1.3.0, 2.0.0-rc1 ≤ v < 2.0.0-rc2 | 1.3.0, 2.0.0-rc2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.