CVE-2022-36068

High

Description

Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, a moderator can create new and edit existing themes by using the API when they should not be able to do so. The problem is patched in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.

SeverityHigh
CVSS7.2
Exploit probability—
ProductDiscourse
PublishedSep 29, 2022
First seenSep 29, 2022

How to fix

Update
  • discourse discourse2.8.9 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 2.8.9, 2.9.02.8.9

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.