CVE-2022-36102

Medium

Description

Shopware is an open source e-commerce software. In affected versions if backend admin controllers are called with a certain notation, the ACL could be bypassed. Users could execute actions, which they are normally not able to do. Users are advised to update to the current version (5.7.15). Users can get the update via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

SeverityMedium
CVSS6.3
Exploit probability—
ProductShopware
PublishedSep 12, 2022
First seenSep 12, 2022
Weakness typeCWE-281CWE-281

How to fix

Update
  • shopware shopware5.7.15 or later
  • shopware/shopware5.7.15 or later

Affected products

ProductAffected versionsFixed in
shopware shopware5.0.0 ≤ v < 5.7.155.7.15
shopware/shopwarePackagistv < 5.7.155.7.15

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.