CVE-2022-36107
Description
TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `FileDumpController` (backend and frontend context) is vulnerable to cross-site scripting when malicious files are displayed using this component. A valid backend user account is needed to exploit this vulnerability. Update to TYPO3 version 7.6.58 ELTS, 8.7.48 ELTS, 9.5.37 ELTS, 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.
How to fix
- typo3/cms-core7.6.58, 8.7.48, 9.5.37, 10.4.32, 11.5.16 or later
- typo3/cms10.4.32, 11.5.16 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| typo3 typo3 | 7.0.0 ≤ v ≤ 7.6.57, 8.0.0 ≤ v ≤ 8.7.47, 9.0.0 ≤ v ≤ 9.5.36, 10.0.0 ≤ v ≤ 10.4.31, 11.0.0 ≤ v ≤ 11.5.15 | — |
| typo3/cms-corePackagist | 7.0.0 ≤ v < 7.6.58, 8.0.0 ≤ v < 8.7.48, 9.0.0 ≤ v < 9.5.37, 10.0.0 ≤ v < 10.4.32, 11.0.0 ≤ v < 11.5.16 | 7.6.58, 8.7.48, 9.5.37, 10.4.32, 11.5.16 |
| typo3/cmsPackagist | 10.0.0 ≤ v < 10.4.32, 11.0.0 ≤ v < 11.5.16 | 10.4.32, 11.5.16 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.