CVE-2022-36108

Medium

Description

TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `f:asset.css` view helper is vulnerable to cross-site scripting when user input is passed as variables to the CSS. Update to TYPO3 version 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductTypo3
PublishedSep 13, 2022
First seenSep 13, 2022

How to fix

Update
  • typo3/cms-core10.4.32, 11.5.16 or later
  • typo3/cms10.4.32, 11.5.16 or later

Affected products

ProductAffected versionsFixed in
typo3 typo310.0.0 ≤ v ≤ 10.4.31, 11.0.0 ≤ v ≤ 11.5.15—
typo3/cms-corePackagist10.3.0 ≤ v < 10.4.32, 11.0.0 ≤ v < 11.5.1610.4.32, 11.5.16
typo3/cmsPackagist10.3.0 ≤ v < 10.4.32, 11.0.0 ≤ v < 11.5.1610.4.32, 11.5.16

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.