CVE-2022-37021
Description
Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.
How to fix
- org.apache.geode:geode-core1.12.16, 1.13.5, 1.14.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache geode | v ≤ 1.12.5, 1.13.0 ≤ v ≤ 1.13.4, 1.14.0 | — |
| org.apache.geode:geode-coreMaven | v < 1.12.16, 1.13.0 ≤ v < 1.13.5, 1.14.0 ≤ v < 1.14.1 | 1.12.16, 1.13.5, 1.14.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.