CVE-2022-37023

Medium

Description

Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.

SeverityMedium
CVSS6.5
Exploit probability78. percentile1.8%
ProductApache Geode
PublishedAug 31, 2022
First seenAug 31, 2022

How to fix

Update
  • apache geode1.15.0 or later
  • org.apache.geode:geode-core1.15.0 or later

Affected products

ProductAffected versionsFixed in
apache geodev < 1.15.01.15.0
org.apache.geode:geode-coreMavenv < 1.15.01.15.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.