CVE-2022-3705

Medium

Description

A vulnerability was found in vim and classified as problematic. Affected by this issue is the function qf_update_buffer of the file quickfix.c of the component autocmd Handler. The manipulation leads to use after free. The attack may be launched remotely. Upgrading to version 9.0.0805 is able to address this issue. The name of the patch is d0fab10ed2a86698937e3c3fed2f10bd9bb5e731. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-212324.

SeverityMedium
CVSS5.0
Exploit probability—
ProductVim
PublishedOct 26, 2022
First seenOct 26, 2022

How to fix

Affected products

ProductAffected versionsFixed in
vim vimv < 9.0.08059.0.0805
fedoraproject fedora35, 36—
debian debian_linux10.0—
netapp active_iq_unified_managerNo range specified—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.