CVE-2022-39211
Description
Nextcloud server is an open source personal cloud platform. In affected versions it was found that locally running webservices can be found and requested erroneously. It is recommended that the Nextcloud Server is upgraded to 23.0.8 or 24.0.4. It is recommended that the Nextcloud Enterprise Server is upgraded to 22.2.10.4, 23.0.8 or 24.0.4. There are no known workarounds for this issue.
How to fix
- nextcloud nextcloud_enterprise_server22.2.10.4, 23.0.8, 24.0.4 or later
- nextcloud nextcloud_server23.0.8, 24.0.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| nextcloud nextcloud_enterprise_server | v < 22.2.10.4, 23.0.0 ≤ v < 23.0.8, 24.0.0 ≤ v < 24.0.4 | 22.2.10.4, 23.0.8, 24.0.4 |
| nextcloud nextcloud_server | v < 23.0.8, 24.0.0 ≤ v < 24.0.4 | 23.0.8, 24.0.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.