CVE-2022-39231
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.
How to fix
- parseplatform parse-server4.10.16, 5.2.7 or later
- parse-server4.10.16, 5.2.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 4.10.16, 5.0.0 ≤ v < 5.2.7 | 4.10.16, 5.2.7 |
| parse-servernpm | v < 4.10.16, 5.0.0 ≤ v < 5.2.7 | 4.10.16, 5.2.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.