CVE-2022-39263

Medium

Description

`@next-auth/upstash-redis-adapter` is the Upstash Redis adapter for NextAuth.js, which provides authentication for Next.js. Applications that use `next-auth` Email Provider and `@next-auth/upstash-redis-adapter` before v3.0.2 are affected by this vulnerability. The Upstash Redis adapter implementation did not check for both the identifier (email) and the token, but only checking for the identifier when verifying the token in the email callback flow. An attacker who knows about the victim's email could easily sign in as the victim, given the attacker also knows about the verification token's expired duration. The vulnerability is patched in v3.0.2. A workaround is available. Using Advanced Initialization, developers can check the requests and compare the query's token and identifier before proceeding.

SeverityMedium
CVSS6.8
Exploit probability—
ProductNextauth.js Next-auth
PublishedSep 28, 2022
First seenSep 28, 2022

How to fix

Update
  • nextauth.js next-auth3.0.2 or later
  • @next-auth/upstash-redis-adapter3.0.2 or later

Affected products

ProductAffected versionsFixed in
nextauth.js next-authv < 3.0.23.0.2
@next-auth/upstash-redis-adapternpmv < 3.0.23.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.