CVE-2022-39272

Medium

Description

Flux is an open and extensible continuous delivery solution for Kubernetes. Versions prior to 0.35.0 are subject to a Denial of Service. Users that have permissions to change Flux’s objects, either through a Flux source or directly within a cluster, can provide invalid data to fields `.spec.interval` or `.spec.timeout` (and structured variations of these fields), causing the entire object type to stop being processed. This issue is patched in version 0.35.0. As a workaround, Admission controllers can be employed to restrict the values that can be used for fields `.spec.interval` and `.spec.timeout`, however upgrading to the latest versions is still the recommended mitigation.

SeverityMedium
CVSS5.0
Exploit probability—
ProductFluxcd Flux2
PublishedOct 22, 2022
First seenOct 22, 2022
Weakness typeCWE-1284CWE-1284

How to fix

Update
  • fluxcd flux20.35.0 or later
  • fluxcd helm-controller0.24.0 or later
  • fluxcd image-automation-controller0.26.0 or later
  • fluxcd image-reflector-controller0.22.0 or later
  • fluxcd kustomize-controller0.29.0 or later
  • fluxcd notification-controller0.27.0 or later
  • fluxcd source-controller0.30.0 or later
  • github.com/fluxcd/flux20.35.0 or later
  • github.com/fluxcd/source-controller0.30.0 or later
  • github.com/fluxcd/kustomize-controller0.29.0 or later
  • github.com/fluxcd/helm-controller0.24.0 or later
  • github.com/fluxcd/notification-controller0.27.0 or later

Affected products

ProductAffected versionsFixed in
fluxcd flux20.1.0 ≤ v < 0.35.00.35.0
fluxcd helm-controller0.0.2 ≤ v < 0.24.0, 0.0.10.24.0
fluxcd image-automation-controller0.1.0 ≤ v < 0.26.00.26.0
fluxcd image-reflector-controller0.1.0 ≤ v < 0.22.00.22.0
fluxcd kustomize-controller0.0.2 ≤ v < 0.29.0, 0.0.10.29.0
fluxcd notification-controller0.0.2 ≤ v < 0.27.0, 0.0.10.27.0
fluxcd source-controller0.0.2 ≤ v < 0.30.0, 0.0.10.30.0
github.com/fluxcd/flux2Go0.1.0 ≤ v < 0.35.00.35.0
github.com/fluxcd/source-controllerGo0.0.1-alpha-1 ≤ v < 0.30.00.30.0
github.com/fluxcd/kustomize-controllerGo0.0.1-alpha-1 ≤ v < 0.29.00.29.0
github.com/fluxcd/helm-controllerGo0.0.1-alpha-1 ≤ v < 0.24.00.24.0
github.com/fluxcd/notification-controllerGo0.0.1-alpha-1 ≤ v < 0.27.00.27.0
github.com/fluxcd/image-automation-controllerGo0.1.0 ≤ v < 0.26.00.26.0
github.com/fluxcd/image-reflector-controllerGo0.1.0 ≤ v < 0.22.00.22.0
github.com/fluxcd/helm-controller/apiGov < 0.26.00.26.0
github.com/fluxcd/image-automation-controller/apiGov < 0.26.10.26.1
github.com/fluxcd/image-reflector-controller/apiGov < 0.22.10.22.1
github.com/fluxcd/kustomize-controller/apiGov < 0.30.00.30.0
github.com/fluxcd/notification-controller/apiGov < 0.28.00.28.0
github.com/fluxcd/source-controller/apiGov < 0.30.00.30.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.