CVE-2022-39284

Low

Description

CodeIgniter is a PHP full-stack web framework. In versions prior to 4.2.7 setting `$secure` or `$httponly` value to `true` in `Config\Cookie` is not reflected in `set_cookie()` or `Response::setCookie()`. As a result cookie values are erroneously exposed to scripts. It should be noted that this vulnerability does not affect session cookies. Users are advised to upgrade to v4.2.7 or later. Users unable to upgrade are advised to manually construct their cookies either by setting the options in code or by constructing Cookie objects. Examples of each workaround are available in the linked GHSA.

SeverityLow
CVSS2.6
Exploit probability—
ProductCodeigniter
PublishedOct 6, 2022
First seenOct 6, 2022
Weakness typeCWE-665CWE-665

How to fix

Update
  • codeigniter codeigniter4.2.7 or later
  • codeigniter4/framework4.2.7 or later

Affected products

ProductAffected versionsFixed in
codeigniter codeigniter4.0.0 ≤ v < 4.2.74.2.7
codeigniter4/frameworkPackagistv < 4.2.74.2.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2022-39284 · Codeigniter · Dark Radar