CVE-2022-39297

High

Description

MelisCms provides a full CMS for Melis Platform, including templating system, drag'n'drop of plugins, SEO and many administration tools. Attackers can deserialize arbitrary data on affected versions of `melisplatform/melis-cms`, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to `melisplatform/melis-cms` >= 5.0.1. This issue was addressed by restricting allowed classes when deserializing user-controlled data.

SeverityHigh
CVSS7.7
Exploit probability—
ProductMelistechnology Meliscms
PublishedOct 12, 2022
First seenOct 12, 2022

How to fix

Update
  • melistechnology meliscms5.0.1 or later
  • melisplatform/melis-cms5.0.1 or later

Affected products

ProductAffected versionsFixed in
melistechnology meliscmsv < 5.0.15.0.1
melisplatform/melis-cmsPackagistv < 5.0.15.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.