CVE-2022-39299

High

Description

Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disabling SAML authentication may be done as a workaround.

SeverityHigh
CVSS7.4
Exploit probability—
ProductPassport-saml
PublishedOct 12, 2022
First seenOct 12, 2022
Weakness typeCWE-347CWE-347

How to fix

Update
  • passport-saml_project passport-saml3.2.2 or later
  • passport-saml3.2.2 or later
  • node-saml4.0.0-beta.5 or later
  • @node-saml/node-saml4.0.0-beta.5 or later
  • @node-saml/passport-saml4.0.0-beta.3 or later

Affected products

ProductAffected versionsFixed in
passport-saml_project passport-samlv < 3.2.2, 4.0.03.2.2
passport-samlnpmv < 3.2.23.2.2
node-samlnpmv < 4.0.0-beta.54.0.0-beta.5
@node-saml/node-samlnpmv < 4.0.0-beta.54.0.0-beta.5
@node-saml/passport-samlnpmv < 4.0.0-beta.34.0.0-beta.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.