CVE-2022-39300

High

Description

node SAML is a SAML 2.0 library based on the SAML implementation of passport-saml. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to node-saml version 4.0.0-beta5 or newer. Disabling SAML authentication may be done as a workaround.

SeverityHigh
CVSS7.7
Exploit probability—
ProductNode Saml
PublishedOct 13, 2022
First seenOct 13, 2022
Weakness typeCWE-347CWE-347

How to fix

Update
  • node_saml_project node_saml4.0.0 or later
  • node-saml4.0.0-beta.5 or later

Affected products

ProductAffected versionsFixed in
node_saml_project node_samlv < 4.0.0, 4.0.04.0.0
node-samlnpmv < 4.0.0-beta.54.0.0-beta.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.