CVE-2022-39314

Low

Description

Kirby is a flat-file CMS. In versions prior to 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, Kirby is subject to user enumeration due to Improper Restriction of Excessive Authentication Attempts. This vulnerability affects you only if you are using the `code` or `password-reset` auth method with the `auth.methods` option or if you have enabled the `debug` option in production. By using two or more IP addresses and multiple login attempts, valid user accounts will lock, but invalid accounts will not, leading to account enumeration. This issue has been patched in versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1. If you cannot update immediately, you can work around the issue by setting the `auth.methods` option to `password`, which disables the code-based login and password reset forms.

SeverityLow
CVSS3.7
Exploit probability—
ProductKirby
PublishedOct 24, 2022
First seenOct 24, 2022
Weakness typeCWE-307CWE-307

How to fix

Update
  • getkirby kirby3.5.8.2, 3.6.6.2, 3.7.5.1 or later
  • getkirby/cms3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1 or later

Affected products

ProductAffected versionsFixed in
getkirby kirbyv < 3.5.8.2, 3.6.0 ≤ v < 3.6.6.2, 3.7.0 ≤ v < 3.7.5.1, 3.8.03.5.8.2, 3.6.6.2, 3.7.5.1
getkirby/cmsPackagist3.5.0 ≤ v < 3.5.8.2, 3.6.0 ≤ v < 3.6.6.2, 3.7.0 ≤ v < 3.7.5.1, 3.8.0 ≤ v < 3.8.13.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.