CVE-2022-39315
Description
Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.
How to fix
- getkirby kirby3.5.8.2, 3.6.6.2, 3.7.5.1 or later
- getkirby/cms3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| getkirby kirby | v < 3.5.8.2, 3.6.0 ≤ v < 3.6.6.2, 3.7.0 ≤ v < 3.7.5.1, 3.8.0 | 3.5.8.2, 3.6.6.2, 3.7.5.1 |
| getkirby/cmsPackagist | v < 3.5.8.2, 3.6.0 ≤ v < 3.6.6.2, 3.7.0 ≤ v < 3.7.5.1, 3.8.0 ≤ v < 3.8.1 | 3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.