CVE-2022-39352

Medium

Description

OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. Versions prior to 0.2.5 are vulnerable to authorization bypass under certain conditions. You are affected by this vulnerability if you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). This issue has been patched in version v0.2.5. This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.

SeverityMedium
CVSS4.8
Exploit probability—
ProductOpenfga
PublishedNov 8, 2022
First seenNov 8, 2022

How to fix

Update
  • openfga openfga0.2.5 or later
  • github.com/openfga/openfga0.2.5 or later

Affected products

ProductAffected versionsFixed in
openfga openfgav < 0.2.50.2.5
github.com/openfga/openfgaGov < 0.2.50.2.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.