CVE-2022-39358
Medium
Description
Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, and 1.42.6, it was possible to circumvent locked parameters when requesting data for a question in an embedded dashboard by constructing a malicious request to the backend. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, and 1.42.6.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Metabase
PublishedOct 26, 2022
First seenOct 26, 2022
Weakness typeCWE-200Sensitive information exposure
How to fix
Update
- metabase metabase0.42.6, 0.43.7, 0.44.5, 1.42.6, 1.43.7, 1.44.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| metabase metabase | 0.42.0 ≤ v < 0.42.6, 0.43.0 ≤ v < 0.43.7, 0.44.0 ≤ v < 0.44.5, 1.42.0 ≤ v < 1.42.6, 1.43.0 ≤ v < 1.43.7, 1.44.0 ≤ v < 1.44.5 | 0.42.6, 0.43.7, 0.44.5, 1.42.6, 1.43.7, 1.44.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.