CVE-2022-39361
Description
Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, H2 (Sample Database) could allow Remote Code Execution (RCE), which can be abused by users able to write SQL queries on H2 databases. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer allows DDL statements in H2 native queries.
How to fix
- metabase metabase0.41.9, 0.42.6, 0.43.7, 0.44.5, 1.41.9, 1.42.6, 1.43.7, 1.44.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| metabase metabase | 0.41.0 ≤ v < 0.41.9, 0.42.0 ≤ v < 0.42.6, 0.43.0 ≤ v < 0.43.7, 0.44.0 ≤ v < 0.44.5, 1.41.0 ≤ v < 1.41.9, 1.42.0 ≤ v < 1.42.6, 1.43.0 ≤ v < 1.43.7, 1.44.0 ≤ v < 1.44.5 | 0.41.9, 0.42.6, 0.43.7, 0.44.5, 1.41.9, 1.42.6, 1.43.7, 1.44.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.