CVE-2022-39396
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.18, and prior to 5.3.1 on the 5.X branch, are vulnerable to Remote Code Execution via prototype pollution. An attacker can use this prototype pollution sink to trigger a remote code execution through the MongoDB BSON parser. This issue is patched in version 5.3.1 and in 4.10.18. There are no known workarounds.
How to fix
- parseplatform parse-server4.10.18, 5.3.1 or later
- parse-server4.10.18, 5.3.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| parseplatform parse-server | v < 4.10.18, 5.0.0 ≤ v < 5.3.1 | 4.10.18, 5.3.1 |
| parse-servernpm | v < 4.10.18, 5.0.0 ≤ v < 5.3.1 | 4.10.18, 5.3.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.