CVE-2022-40816

Medium

Description

Zammad 5.2.1 is vulnerable to Incorrect Access Control. Zammad's asset handling mechanism has logic to ensure that customer users are not able to see personal information of other users. This logic was not effective when used through a web socket connection, so that a logged-in attacker would be able to fetch personal data of other users by querying the Zammad API. This issue is fixed in , 5.2.2.

SeverityMedium
CVSS6.5
Exploit probability—
ProductZammad
PublishedSep 27, 2022
First seenSep 27, 2022

How to fix

Update
  • zammad zammad5.2.2 or later

Affected products

ProductAffected versionsFixed in
zammad zammad5.2.0 ≤ v < 5.2.25.2.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.