CVE-2022-40955

High

Description

In versions of Apache InLong prior to 1.3.0, an attacker with sufficient privileges to specify MySQL JDBC connection URL parameters and to write arbitrary data to the MySQL database, could cause this data to be deserialized by Apache InLong, potentially leading to Remote Code Execution on the Apache InLong server. Users are advised to upgrade to Apache InLong 1.3.0 or newer.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Inlong
PublishedSep 20, 2022
First seenSep 20, 2022

How to fix

Update
  • apache inlong1.3.0 or later
  • org.apache.inlong:inlong-common1.3.0 or later

Affected products

ProductAffected versionsFixed in
apache inlongv < 1.3.01.3.0
org.apache.inlong:inlong-commonMavenv < 1.3.01.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2022-40955 · Apache Inlong · Dark Radar