CVE-2022-41317
Medium
Description
An issue was discovered in Squid 4.9 through 4.17 and 5.0.6 through 5.6. Due to inconsistent handling of internal URIs, there can be Exposure of Sensitive Information about clients using the proxy via an HTTPS request to an internal cache manager URL. This is fixed in 5.7.
SeverityMedium
CVSS6.5
Exploit probability—
ProductSquid
PublishedDec 25, 2022
First seenDec 25, 2022
Weakness typeCWE-697CWE-697
How to fix
Update
- squid-cache squid5.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| squid-cache squid | 4.9 ≤ v ≤ 4.17, 5.0.6 ≤ v < 5.7 | 5.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.