CVE-2022-41318
High
Description
A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.
SeverityHigh
CVSS8.6
Exploit probability—
ProductSquid
PublishedDec 25, 2022
First seenDec 25, 2022
Weakness typeCWE-190Integer overflow
How to fix
Update
- squid-cache squid5.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| squid-cache squid | 2.5 ≤ v < 5.7 | 5.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.