CVE-2022-41556
High
Description
A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Lighttpd
PublishedOct 6, 2022
First seenOct 6, 2022
How to fix
Update
- lighttpd lighttpd1.4.67 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| lighttpd lighttpd | 1.4.56 ≤ v < 1.4.67 | 1.4.67 |
| fedoraproject fedora | 35 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.