CVE-2022-41881
Medium
Description
Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.
SeverityMedium
CVSS5.3
Exploit probability—
Product
Netty
PublishedDec 12, 2022
First seenDec 12, 2022
Weakness typeCWE-674CWE-674
How to fix
Update
- netty netty4.1.86 or later
- io.netty:netty-codec-haproxy4.1.86.Final or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| netty netty | v < 4.1.86 | 4.1.86 |
| debian debian_linux | 10.0, 11.0 | — |
| io.netty:netty-codec-haproxyMaven | v < 4.1.86.Final | 4.1.86.Final |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.