CVE-2022-41892
Description
Arches is a web platform for creating, managing, & visualizing geospatial data. Versions prior to 6.1.2, 6.2.1, and 7.1.2 are vulnerable to SQL Injection. With a carefully crafted web request, it's possible to execute certain unwanted sql statements against the database. This issue is fixed in version 7.12, 6.2.1, and 6.1.2. Users are recommended to upgrade as soon as possible. There are no workarounds.
How to fix
- arches6.1.2, 6.2.1, 7.2.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| archesproject arches | v ≤ 6.1.1, 6.2.0, 7.0.0, 7.1.0, 7.1.1 | — |
| archesPyPI | v < 6.1.2, 6.2.0 ≤ v < 6.2.1, 7.0.0 ≤ v < 7.2.0 | 6.1.2, 6.2.1, 7.2.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.