CVE-2022-41905
High
Description
WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.
SeverityHigh
CVSS8.2
Exploit probability—
ProductWsgidav
PublishedNov 11, 2022
First seenNov 11, 2022
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- wsgidav_project wsgidav4.1.0 or later
- wsgidav4.1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| wsgidav_project wsgidav | 3.0.0 ≤ v < 4.1.0 | 4.1.0 |
| wsgidavPyPI | 3.0.0a1 ≤ v < 4.1.0, 3.0.0 ≤ v < 4.1.0 | 4.1.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.