CVE-2022-41921

Low

Description

Discourse is an open-source discussion platform. Prior to version 2.9.0.beta13, users can post chat messages of an unlimited length, which can cause a denial of service for other users when posting huge amounts of text. Users should upgrade to version 2.9.0.beta13, where a limit has been introduced. No known workarounds are available.

SeverityLow
CVSS3.5
Exploit probability—
ProductDiscourse
PublishedNov 28, 2022
First seenNov 28, 2022

How to fix

Update
  • discourse discourse2.9.0 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 2.9.0, 2.9.02.9.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.