CVE-2022-41942

High

Description

Sourcegraph is a code intelligence platform. In versions prior to 4.1.0 a command Injection vulnerability existed in the gitserver service, present in all Sourcegraph deployments. This vulnerability was caused by a lack of input validation on the host parameter of the `/list-gitolite` endpoint. It was possible to send a crafted request to gitserver that would execute commands inside the container. Successful exploitation requires the ability to send local requests to gitserver. The issue is patched in version 4.1.0.

SeverityHigh
CVSS7.9
Exploit probability—
ProductSourcegraph
PublishedNov 22, 2022
First seenNov 22, 2022

How to fix

Update
  • sourcegraph sourcegraph4.1.0 or later

Affected products

ProductAffected versionsFixed in
sourcegraph sourcegraphv < 4.1.04.1.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.