CVE-2022-41947
Description
DHIS 2 is an open source information system for data capture, management, validation, analytics and visualization. Through various features of DHIS2, an authenticated user may be able to upload a file which includes embedded javascript. The user could then potentially trick another authenticated user to open the malicious file in a browser which would trigger the javascript code, resulting in a cross-site scripting (XSS) attack. DHIS2 administrators should upgrade to the following hotfix releases: 2.36.12.1, 2.37.8.1, 2.38.2.1, 2.39.0.1. Users unable to upgrade may add the following simple CSP rule in your web proxy to the vulnerable endpoints: `script-src 'none'`. This workaround will prevent all javascript from running on those endpoints.
How to fix
- dhis2 dhis_22.36.12.1, 2.37.8.1, 2.38.2.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| dhis2 dhis_2 | 2.35.0 ≤ v < 2.36.12.1, 2.37.0 ≤ v < 2.37.8.1, 2.38.0 ≤ v < 2.38.2.1, 2.39.0 | 2.36.12.1, 2.37.8.1, 2.38.2.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.