CVE-2022-42009

High

Description

SpringEL injection in the server agent in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.

SeverityHigh
CVSS8.0
Exploit probability—
ProductApache Ambari
PublishedJul 12, 2023
First seenJul 12, 2023

How to fix

Update
  • apache ambari2.7.7 or later
  • org.apache.ambari:ambari2.7.7 or later

Affected products

ProductAffected versionsFixed in
apache ambari2.7.0 ≤ v < 2.7.72.7.7
org.apache.ambari:ambariMaven2.7.0 ≤ v < 2.7.72.7.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.