CVE-2022-42890
High
Description
A vulnerability in Batik of Apache XML Graphics allows an attacker to run Java code from untrusted SVG via JavaScript. This issue affects Apache XML Graphics prior to 1.16. Users are recommended to upgrade to version 1.16.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Batik
PublishedOct 25, 2022
First seenOct 25, 2022
How to fix
Update
- apache batik1.16 or later
- org.apache.xmlgraphics:batik1.16 or later
- org.apache.xmlgraphics:batik-bridge1.16 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache batik | 1.0 ≤ v < 1.16 | 1.16 |
| debian debian_linux | 10.0, 11.0 | — |
| org.apache.xmlgraphics:batikMaven | v < 1.16 | 1.16 |
| org.apache.xmlgraphics:batik-bridgeMaven | v < 1.16 | 1.16 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.