CVE-2022-42900

High

Description

Bentley MicroStation and MicroStation-based applications may be affected by out-of-bounds read issues when opening crafted FBX files. Exploiting these issues could lead to information disclosure and code execution. The fixed versions are 10.17.01.58* for MicroStation and 10.17.01.19* for Bentley View.

SeverityHigh
CVSS7.8
Exploit probability—
ProductBentley Microstation
PublishedOct 13, 2022
First seenOct 13, 2022

How to fix

Update
  • bentley microstation10.17.01.58 or later
  • bentley view10.17.01.19 or later

Affected products

ProductAffected versionsFixed in
bentley microstationv < 10.17.01.5810.17.01.58
bentley viewv < 10.17.01.1910.17.01.19

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.