CVE-2022-42920

Critical

Description

Apache Commons BCEL has a number of APIs that would normally only allow changing specific class characteristics. However, due to an out-of-bounds writing issue, these APIs can be used to produce arbitrary bytecode. This could be abused in applications that pass attacker-controllable data to those APIs, giving the attacker more control over the resulting bytecode than otherwise expected. Update to Apache Commons BCEL 6.6.0.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Commons Bcel
PublishedNov 7, 2022
First seenNov 7, 2022

How to fix

Affected products

ProductAffected versionsFixed in
apache commons_bcelv < 6.6.06.6.0
fedoraproject fedora35, 36, 37—
org.apache.bcel:bcelMavenv < 6.6.06.6.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.