CVE-2022-43695
Description
Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Stored Cross-Site Scripting (XSS) in dashboard/system/express/entities/associations because Concrete CMS allows association with an entity name that doesn’t exist or, if it does exist, contains XSS since it was not properly sanitized. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.
How to fix
- concretecms concrete_cms8.5.10 or later
- concrete5/concrete58.5.10, 9.1.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| concretecms concrete_cms | v < 8.5.10, 9.0.0 ≤ v ≤ 9.1.2 | 8.5.10 |
| concrete5/concrete5Packagist | v < 8.5.10, 9.0.0 ≤ v < 9.1.3 | 8.5.10, 9.1.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.