CVE-2022-43766

High

Description

Apache IoTDB version 0.12.2 to 0.12.6, 0.13.0 to 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. Users should upgrade to 0.13.3 which addresses this issue or use a later version of Java to avoid it.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Iotdb
PublishedOct 26, 2022
First seenOct 26, 2022

How to fix

Update
  • org.apache.iotdb:flink-tsfile-connector0.13.3 or later
  • apache-iotdb0.13.3 or later
  • org.apache.iotdb:iotdb-server0.13.3 or later
  • org.apache.iotdb:tsfile0.13.3 or later

Affected products

ProductAffected versionsFixed in
apache iotdb0.12.2 ≤ v ≤ 0.12.6, 0.13.0 ≤ v ≤ 0.13.2—
org.apache.iotdb:flink-tsfile-connectorMaven0.12.2 ≤ v < 0.13.30.13.3
apache-iotdbPyPI0.12.2 ≤ v < 0.13.30.13.3
org.apache.iotdb:iotdb-serverMaven0.12.2 ≤ v < 0.13.30.13.3
org.apache.iotdb:tsfileMaven0.12.2 ≤ v < 0.13.30.13.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.