CVE-2022-43974
High
Description
MatrixSSL 4.0.4 through 4.5.1 has an integer overflow in matrixSslDecodeTls13. A remote attacker might be able to send a crafted TLS Message to cause a buffer overflow and achieve remote code execution. This is fixed in 4.6.0.
SeverityHigh
CVSS8.1
Exploit probability—
ProductMatrixssl
PublishedJan 9, 2023
First seenJan 9, 2023
Weakness typeCWE-190Integer overflow
How to fix
Update
- matrixssl matrixssl4.6.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| matrixssl matrixssl | 4.0.0 ≤ v < 4.6.0 | 4.6.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.