CVE-2022-44572

High

Description

A denial of service vulnerability in the multipart parsing component of Rack fixed in 2.0.9.2, 2.1.4.2, 2.2.4.1 and 3.0.0.1 could allow an attacker tocraft input that can cause RFC2183 multipart boundary parsing in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that parse multipart posts using Rack (virtually all Rails applications) are impacted.

SeverityHigh
CVSS7.5
Exploit probability—
ProductRack
PublishedFeb 9, 2023
First seenFeb 9, 2023

How to fix

Update
  • rack rack2.0.9.2, 2.1.4.2, 2.2.4.1 or later

Affected products

ProductAffected versionsFixed in
rack rackv < 2.0.9.2, 2.1.0 ≤ v < 2.1.4.2, 2.2.0 ≤ v < 2.2.4.12.0.9.2, 2.1.4.2, 2.2.4.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.