CVE-2022-44645

High

Description

In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Linkis
PublishedJan 31, 2023
First seenJan 31, 2023

How to fix

Update
  • org.apache.linkis:linkis1.3.1 or later

Affected products

ProductAffected versionsFixed in
apache linkisv ≤ 1.3.0—
org.apache.linkis:linkisMavenv < 1.3.11.3.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.