CVE-2022-44729

High

Description

Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16. On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.

SeverityHigh
CVSS7.1
Exploit probability—
ProductApache Xml Graphics Batik
PublishedAug 22, 2023
First seenAug 22, 2023

How to fix

Update
  • org.apache.xmlgraphics:batik-bridge1.17 or later
  • org.apache.xmlgraphics:batik-svgrasterizer1.17 or later
  • org.apache.xmlgraphics:batik-transcoder1.17 or later

Affected products

ProductAffected versionsFixed in
apache xml_graphics_batik1.0 ≤ v ≤ 1.16—
debian debian_linux10.0—
org.apache.xmlgraphics:batik-bridgeMaven1.0 ≤ v < 1.171.17
org.apache.xmlgraphics:batik-svgrasterizerMaven1.0 ≤ v < 1.171.17
org.apache.xmlgraphics:batik-transcoderMaven1.0 ≤ v < 1.171.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.